Export processing delayed
Incident Report for Onfleet
Postmortem

At 2022-11-01 6:50 UTC, an export error occurred that caused the corresponding queue worker to stop processing other exports. The same error had been missed previously which had caused other export queue workers to fail in the same way. As such, no further exports could be processed until the error was resolved. Once we became aware of the issue, we resolved the issue by 2022-11-01 10:52 UTC. All of the previously deferred exports were processed by 2022-11-01 11:07 UTC.

We apologize for any interruption this deferred processing may have caused. We are validating a fix for the root cause of this issue which will be released when ready. We will improve our monitoring procedures to ensure that we respond more quickly in any similar future situations if they arise.

Posted Nov 07, 2022 - 17:11 PST

Resolved
This incident has been resolved.
Posted Nov 01, 2022 - 04:18 PDT
Monitoring
An issue with export caused processing to be delayed.

Previously delayed exports have now been processed.

We are currently monitoring.
Posted Nov 01, 2022 - 04:11 PDT
This incident affected: Dashboard.